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Introduction 

Since the TopSolid 2019 version (version 6.20), the installation interface has been modified. 

This tutorial is a step-by-step summary of the instructions to follow in order to install the software and its licenses. 
However, before any installation, it is advisable to think about how to set up the licenses based on specific needs. 

Different procedures are therefore described according to the installation framework: 

- Installation of TopSolid with standalone license 
- Installation of a license server and several client workstations 

System Requirements Since Version 6.22 

This requirement is updated on the TopSolid website in the SERVICES > Requirements section. 

www.topsolid.com 

Compatible operating systems 

- Windows 7 64-bit 
- Windows 8 and 8.1 (version 6.14 minimum) 
- Windows 10 Pro 64-bit (version 6.17 minimum) 

WinRT and Windows 10 S are not compatible. 

Note: TopSolid strongly advises against the use of Avast and Trend Micro anti-virus software because they generate 
false alerts with the TopSolid files. 

Equipment and hardware 

- Intel i3, i5 and i7 processor-based machine 
- Random Access Memory: 16 GB 
- 1 TB hard drive 
- Graphics resolution 1280x1024 
- Keyboard and mouse (preferably with the wheel) 
- DVD player 
- Parallel or USB port (to connect the protection key) 
- Internet Explorer 6 minimum (for online help) 

Graphic cards 

TopSolid has been optimized to use the latest nVidia GeForce, Quadro and AMD Radeon Pro cards. 
  

file:///C:/Users/sheneil-e/Downloads/www.topsolid.com
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TopSolid v6 Setup 

Download using TopSolid'Downloader 

• Download and run the TopSolid'Downloader program using the link received by email. 

 

• Indicate the download path to install TopSolid. 

• Click on the Download button. 

Note: If TopSolid should not be installed on the computer that is downloading the version, you simply have to 
uncheck the Launch Setup at the end of the download box. 

Software installation on user workstations 

After launching the setup, the installation interface is displayed. 

• Select the products to be installed and select the paths according to the numbered information detailed below. 
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1: TopSolid and Tools tabs 

These tabs regroup the different products available for installation. 

• Check only the items associated with your licenses. 

TopSolid tab 

For TopSolid'Wood (CAD) customers, you simply have to check the TopSolid'Wood box. 
For TopSolid'WoodCam customers (CAD + CAM), you simply have to check the TopSolid'WoodCam box. 
All the necessary modules, Textures and Libraries, are automatically selected. 

Tools tab 

You simply have to leave the elements checked by default (TopSolid'Update and Sentinel Protection Installer). 
If necessary, you can check the other modules (see the Additional Features of the TopSolid v6 Setup chapter). 

 

2: Installation folder 

• Leave the default path indicated for the location of the installation folder. 

3: Configuration folder 

This folder contains the TopSolid settings specific to each user’s workstation such as interface customization, screen 
background color, keyboard shortcuts, etc. 

By default, this folder will contain the TopSolid authorization code file (top.cod). 

When installing TopSolid for the first time, the Config folder is located in "C:\Missler\Config". We recommend that 
you create a Config folder specific to each version installed. For example, for version 2021, the configuration folder 
could be "C:\Missler\Config 2021". For version 2022, the configuration folder would be "C:\Missler\Config 2022". 

The advantage of this method is to make each installed version independent. Merging the configuration folders will 
force you to use the latest version of TopSolid. 

Note: The installation folder and the configuration folder cannot be the same. 

4: Group folder 

This folder contains the TopSolid settings specific to the company which will benefit all users (drawing model, 
propagations, materials, etc.). This folder is therefore available on the network so that it can be accessible and used 
by several users. It is important to make sure that each user workstation select the same group folder. Companies 
with a single user workstation can place the \Group folder at the same level as the configuration folder. 

Example: 

- C:\Missler\Config 2021 
- C:\Missler\Group 2021 
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5: Work folder 

This is a default backup folder for projects. 

Note: Placing this folder in a network location may affect the read/write performances. 

• Once the products have been selected and the folder paths filled in, click on the Install button. 

The license agreement is displayed. 

 

• Click on the Accept button. 

The list of products to be installed appears. 

• Make sure that nothing is missing or, on the contrary, there are no extra products selected. 

• Click on the Install button. 

The installation can take several minutes. 
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License Installation 

When launching the program, if you do not have a TopSolid license for the current version, the following message 
is displayed. 

 

• Click on the OK button. 

A new dialog box is then displayed. Two choices are available depending on how you manage your license. 

 

Managing standalone licenses 

Cases of licenses associated with a machine ID or a fixed key 

• Click on the Open license file button and confirm the operation. 

The following warning message is displayed. 

 

A notepad document called top.cod opens. 

Note: When opened, this file is automatically created in the configuration folder. 

• Enter the lines of code received by email. To do this, copy and paste the lines of code to avoid typing errors. 

• Save and close the file. 
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Managing floating licenses 

Case of a license server and several client workstations 

License server installation 

Note: This is a server and not a user workstation for server use! 

• On the license server, run the setup.exe file from the installation DVD or from the TopSolid mounted disk 
image. 

The dialog box of the products available for installation is displayed. 

• In the TopSolid tab, uncheck all the boxes. 

• In the Tools tab, check only the Sentinel Protection Installer and Sentinel RMS License Manager boxes. 

 

• Start the installation. 

Sentinel RMS License Manager is the license server and Sentinel Protection Installer is the driver that manages 
the communication with the protection key. 

Adding floating licenses on the server 

• Select a backup folder for the .lic files on the server sent by your sales agency. 

Warning: It is important not to move this folder after completing the following steps, otherwise you may have to 
start all over again. 

• Select the TopSolid v6 DVD drive, follow the TopSolid 6 DVD Drive > Setup > Redist > Sentinel RMS License 
Manager > Tools path, then run the WlmAdmin.exe file. 

• Copy the Tools folder to the license backup folder, then run the WlmAdmin.exe file. 

• Expand the Subnet Servers node. 

• Right-click on the server, select Add Feature > From a File > To Server and its File and then search for each file. 

Note: This step must be performed as many times as there are .lic files. 
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Adding license modules on user workstations 

On each user workstation, TopSolid must be launched in administrator mode to be able to enter the address of 
the license server. 

• Right-click on the TopSolid desktop shortcut and select Run as administrator. 

• Click on the OK button to confirm the operation. 

 

• When the program is launched, the license management dialog box is displayed. Enter the name of the license 
server or the IP address in the dialog bar. 

• Click on the Submit button. 

This step automatically creates the LSFORCEHOST environment variable (selection of a single license server). This 
variable is available in Control Panel > System > Advanced system settings > Environment Variables or by typing 
"variable" in the Windows command bar and selecting Edit system environment variables. 

The LSFORCEHOST environment variable can be used to force the application to search for a computer with only 
one license server (saves time when searching for the server). If the license server indicated in the variable cannot 
be found, the application stops the search and sends an error message. 
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Once the address of the license server has been entered, you have to link the licenses of the modules to be used. 
To do this, several solutions are possible. 

Solution using a "top.cod" file per user (common method) 

• On each workstation, declare the floating license modules in the top.cod file. Insert one line per module as 
TOPSOLID/Module No./Version No. and PolePpSa/Module No./Version No. for the PostPro licenses. 

 

Reminder: The top.cod file is available by clicking on the Open license file button in the dialog box that appears 
when starting TopSolid or in the Config folder. To know the path of the top.cod file, you simply have to go back to 
the TopSolid software and select the Help > Codes command. 

 

Solution using a "top.cod" file centralized on the server 

This solution has the advantage of allowing the license administrator to manage the allocation of licenses to each 
client workstation and to manage only one license file. 

• From the TopSolid software, select the Help > Configuration command. Make sure that all workstations have 
the same path to the TOPGROUP folder. 

• Create a blank .txt file from the notepad and name it top.cod. 

• Open this file and detail the allocation of modules workstation by workstation with the following syntax:  

- PC1: TOPSOLID/Module No./Version No. 
- PC2: TOPSOLID/Module No./Version No. 
- PC3: TOPSOLID/Module No./Version No. 
- etc. 
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PC1, PC2, PC3 must be replaced by the computer name of the company's subnet. 

Note: For the post-processor license, the syntax is PolePpSa/Module No./Version No. 

Desktop shortcut solution 

This final solution consists of entering an argument in the TopSolid desktop shortcut of the appropriate version. 
This method allows management without filling in the top.cod file. 

• Right-click on the appropriate shortcut and select Properties. 

• In the Target field, enter -fTOPSOLID/Module No./Version No. followed by version no.exe. 

• Replace Module No. with one of the floating license module numbers available on the server(s). 

You can request several licenses by cumulating the arguments: top621.exe -fTOPSOLID/200/6.22 -
fTOPSOLID/2/6.22, etc. 

Note: You can enter the licenses common to all workstations and/or the unlimited licenses for the post-processors 
in the top.cod file, then customize it by using the necessary licenses from the shortcut. 

Additional license server information 

The protection key is required to identify the server machine. Only licenses generated with the key identification 
number can be added to the license server. 

The license server runs through a Windows service called Sentinel RMS License Manager and a lservnt.exe process. 
The service automatically starts each time the system is launched. For more information on Sentinel RMS License 
Manager, please refer to the TopSolid media help available in Setup\Redist\Sentinel RMS License 
Manager\Help\Default.htm. 

Notes: 

- You have to make sure that the license server workstation is visible, via the network, by the client 
workstations. 

- The lservnt.exe executable manages the available licenses and their allocation to client workstations. 
- This executable is launched automatically each time the system is rebooted. 
- The lservnt.exe process must be present in the Windows task manager of the license server workstation. It 

should also appear in the list of Windows services in Start mode and Automatic mode. 
- The client and server firewall must have port 5093 open in entry and exit (in UDP mode). 
- If Sentinel RMS License Manager is already installed, its version must be at least version 9.4.0. 
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Additional Configuration 

Language setup 

You have to configure the language using the Help > Configuration command. 

 

Library configuration 

The paths to the user libraries are available in the Tools > Options > Component > User library command. 

 

In the case of several users, it is imperative that the name and path to the libraries are identical and are located on 
a common network server. 

Note: It is preferable to enter short folder names, without using accents or special characters \ / : * < > |. Excessively 
long path documents can lead to loss of links when exporting projects. 

Recommendation: Since these are the standard element libraries to be used in common, the library folder should 
be created in the group configuration folder. The beginning of the path can then be written as $TOPGROUP. 
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• Separate large identifiable assemblies by allowing elements to be managed via the Family, Type, Variant tree 
structure available with the inclusion standard components. 

 

Example: 

Name: Furniture Path: $TOPGROUP/Lib/Furniture 
Name: Hardware Path: $TOPGROUP/Lib/Hardware 

Configuring graphics settings 

You can adjust the graphics settings in the Tools > Options > Display > Settings command. 

 

Increasingly more laptops are equipped with an integrated graphics card coupled with the commonly 
recommended NVIDIA graphics card. Often, the integrated graphics card is used by default. This can however result 
in a decrease in display performance or even graphic issues in TopSolid. 
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In order to overcome these possible issues, it is necessary to perform the following actions. 

• Make sure that your computer's power options are not set to Power saver mode. 

 

• If necessary, open the control panel for your graphics card and then add TopSolid in the program settings to 
assign personalized settings to it. 
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Uninstalling TopSolid v6 

You can now uninstall TopSolid v6 from the same installation setup file. 

The Uninstall All button ensures that all installed applications are removed. 

It is important not to use the Windows program manager. 
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Additional Features of the TopSolid v6 Setup 

PDFCreator 

The installation of PDFCreator is available in the Tools tab of the TopSolid v6 installation menu. 

 

This allows you to have a PDF printer that can be used during the multi-draft. 

TopID 

Since version 6.22, TopID is available in the Tools tab of the TopSolid installation set up file. 

It allows you to know: 

- the protection key number used; 
- the network card ID; 
- the unique identifier. 

 
 
 

What's new in TopSolid 

From the Help tab of the installation menu, you can access the document about the new features of the version 
currently being installed. 

 

Before starting the license setup steps, you simply have to make sure that the server and the user workstations are 
communicating properly. 
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Request Codes 

Standalone license 

With the protection key or on a network card 

• Ask your TopSolid reseller for the codes. 

You have to provide your protection key or your network card number. 

Reminder: To know your key or network card number, you simply have to launch TopSolid and go to Help > Codes. 

Floating license 

When you request licenses for the new version or their renewal from your sales office or TopSolid reseller, it is 
necessary to provide the credentials that you can find via the Wechoid tool of Sentinel RMS. 

Protection key (or Dongle) 

• Browse through the TopSolid setup to launch the Wechoid.exe program available in the TopSolid > Redist > 
Sentinel RMS License Manager > Tools folder. 

• Check only the Computer ID box. 

• Transmit the code available in the Code field. 
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On machine identifier 

• Browse through the TopSolid setup to launch the Wechoid.exe program available in the TopSolid > Redist > 
Sentinel RMS License Manager > Tools folder. 

• Uncheck all boxes except Ethernet Address. 

• Transmit the number available in the Code field to your sales department. 

Note: It is best to copy and paste the code to avoid typos. 
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Advanced 

Floating license server 

Installation on different subnets 

If the client and server workstations are located on different subnets or communicate via the Internet, the following 
actions must be performed: 

- Open port 5093 on the router and firewall. This port is reserved for Sentinel License Manager. 
- Declare the LSPORT environment variable on the client machine with the value 5093 (set LSPORT=5093). 
- Declare the LSERVOPTS environment variable on the server machine with the value -port5093 

(LSPORT=5093). 

Installation on a virtual machine 

You can install a license server and its protection key driver on certain virtual servers. Depending on the type of 
virtualization technology, the USB connectivity is either compatible or not: 

- VirtualBox, VmWare Workstation = USB compatible 
- Hyper-V, Citrix, VmWare ESX = USB not compatible 

This creates a problem as Sentinel RMS License Manager needs to access the USB drive to protect the licenses. 
Protecting a license on a network card ID (MAC address) is not reliable on a virtual server since it can be modified 
very easily. 

Solution 1 

When protecting a license server, a USB hub must be used. This makes the USB drive available on the network. 
Two solutions are recommended by TOPSOLID SAS: 

- Anywhere USB (http://www.digi.com) 
- DongleServers (http://www.dongle-server.com) 

The purchase of these hubs is at the customer's expense. 

Solution 2 

You can generate a license using the MAC address of the network card combined with the UUID. To do this, you 
simply have to use the Wechoid tool and check the Ethernet Address and UUID boxes. The indicated code will have 
to be communicated to generate the license. This license will have to be renewed every year. 

 

http://www.digi.com/
http://www.dongle-server.com/
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Frequent Issues 

Standalone license 

The protection key is not detected at startup 

• Make sure that the protection key is properly plugged in and that it lights up. 

If the protection key does not light up, it means that it is not detected by Windows:  

- If the protection key is red or orange, make sure that the driver is properly installed. 
- To reinstall the driver, you have to relaunch the TopSolid setup and select Sentinel Protection Installer in 

the Tools tab. 

 

- If the protection key is yellow, no driver is required and must not be installed on the workstation. 
- Change the USB port. 

Invalid codes at startup 

Codes are available on the network card, but when launching TopSolid, an error message is displayed indicating 
that the codes are invalid. 

• In the Help > Codes command, make sure that the network card number is the same as the one provided when 
the codes were requested. 

If the codes are not the same, it is possible that this is because the network cards activated when launching TopSolid 
are not the same as when the codes are requested. 

• Try to activate or deactivate the network cards by relaunching TopSolid between each attempt. 

Note: The PC power saver can sometimes disable some network cards. 

License server 

Starting in Demonstration mode 

- On the server: 

• Check the TCP/IP (ping, route...). 

• Make sure that the lservnt.exe process is running. 

• Make sure that the names of the client and server workstations do not contain the "_" or "-" character. 

• The Wechoid utility sends the ID key code (this code is different from the serial number of the key). 
This code must be different from 0. 

• With WlmAdmin, check if there are licenses in the same version as TopSolid. 
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- On the client workstation: 

• Make sure that the workstation has access to the server with WlmAdmin. The name of a server should 
appear. If the client workstation does not find the server, the system environment variable 
LSFORCEHOST = the name of the server can be added. 

• Make sure that a floating license has been accepted by TopSolid. 

• In the event of a sudden shutdown, TopSolid attempts to release the license acquired from the server 
before shutting down. Unfortunately, it is possible that this license will not be released. If the 
application is immediately relaunched but no other license is available, the application will run in 
Demonstration mode. Unused licenses are released after five minutes. You simply have to wait for this 
period of time before relaunching the application. 

Unable to add a license 

When inserting a license in the Sentinel RMS License server, the following message is displayed. 

 

This message indicates that the license does not correspond to the key or ID. Either the floating key is not connected 
or the RMS server is not on the correct server. 

It is also possible to get the following error message when adding the license. 

 

This error message indicates that the license has already been added to the license server. 

Configuration 

Blank configuration following a version update 

When launching a new version of TopSolid, it is possible that the configuration of edges, automatic assembly, 
material overvaluations, etc. is not found. 

• Make sure that the files from the TOPGROUP of the old version have been copied to the TOPGROUP of the 
newly installed version. 

Reminder: You can find out the path to the TOPGROUP using the Help > Configuration command. 

If that still does not work, you will find two folders in the GROUP folder: one folder with the old version number 
and another folder with the new version number. You would have to copy the files from the old version to the 
folder of the new version. 

Example: To switch from TopSolid 2019 to TopSolid 2020, you have to copy and paste the Group/V620 folder into 
the Group/V621 folder. 
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Notes 
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